Module:Navbar/sandbox: Difference between revisions

Content deleted Content added
accept args.vte_links_override
Put the override into "list" but call it "links" instead. Name could still be improved I expect.
Line 132:
local displayed_links
end
if args.vte_links_override then
local displayed_links = choose_links(template, args.vte_links_override)
else
displayed_links = choose_links(template, args)
end
 
local has_brackets = args.brackets
local title_arg = get_title_arg(is_collapsible, template)
local title_text = args[title_arg] or (':' .. mw.getCurrentFrame():getParent():getTitle())
local links = ''
local list = make_list(title_text, has_brackets, displayed_links, is_mini, font_style)
if args.vte_links_override then
div:node(list)
links = vte_links_override
else
local list links = make_list(title_text, has_brackets, displayed_links, is_mini, font_style)
end
 
div:node(listlinks)
 
if is_collapsible then